The PSP-1000 E already compatible with the 6.60 LCFW ME!

October 23rd, 2011, 21:37

300x250uk
Part of the DCEmu Network PSP News..